NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2023-2240 — microweber

HIGHFix: microweber/microweber@f43d5b7

CVE-2023-2240 is a high-severity (CVSS 8.8) Improper Privilege Management vulnerability in microweber/microweber. A fix is available for microweber/microweber — see the affected versions and patch details below.

Improper Privilege Management in microweber/microweber

Also known asGHSA-r6xq-xcxc-fghx
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-2240.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs53th percentile — riskier than 53% of all scored CVEsHighest risk
0.00%0.40%0.80%1.21%0.3%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘microweber/microweber

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Improper Privilege Management in GitHub repository microweber/microweber prior to 1.3.4.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmicroweber/microweberall versions1.3.4composer require microweber/microweber:^1.3.4

Affected Products

1 product · 1 configurations
Application
microwebermicroweber
< 1.3.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for microweber/microweber, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update microweber/microweber to 1.3.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-2240 is resolved across your whole dependency graph.

  3. Workarounds

    Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.

Frequently Asked Questions

Improper Privilege Management in GitHub repository microweber/microweber prior to 1.3.4.
O3 Security · Impact-Aware SCA

Is CVE-2023-2240 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2023-2240: microweber — Fixed in 1.3.4