CVE-2023-2121 — vault
MEDIUMCVE-2023-2121 is a medium-severity (CVSS 4.3) Cross-site Scripting (XSS) vulnerability in github.com/hashicorp/vault. A fix is available for github.com/hashicorp/vault — see the affected versions and patch details below.
Vault’s KV Diff Viewer Allowed for HTML Injection
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-2121.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/hashicorp/vault🐹github.com/hashicorp/vault🐹github.com/hashicorp/vaultReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Vault and Vault Enterprise's (Vault) key-value v2 (kv-v2) diff viewer allowed HTML injection into the Vault web UI through key values. This vulnerability, CVE-2023-2121, is fixed in Vault 1.14.0, 1.13.3, 1.12.7, and 1.11.11.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/hashicorp/vault | all versions | 1.11.11go get github.com/hashicorp/vault@v1.11.11 |
| 🐹Go | github.com/hashicorp/vault | ≥ 1.12.0&&< 1.12.7 | 1.12.7go get github.com/hashicorp/vault@v1.12.7 |
| 🐹Go | github.com/hashicorp/vault | ≥ 1.13.0&&< 1.13.3 | 1.13.3go get github.com/hashicorp/vault@v1.13.3 |
Affected Products
vaulthashicorpDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/hashicorp/vault, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/hashicorp/vault to 1.11.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-2121 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| RHODF-4.14-RHEL-9 | odf4/ocs-rhel9-operator:v4.14.0-67 | RHSA-2023:6832 |
Frequently Asked Questions
Is CVE-2023-2121 in your dependencies?
Find it across Go, including transitive dependencies.