NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
CRITICAL severity

CVE-2023-2106 — calibreweb

CRITICALFix: janeczku/calibre-web@49e4f54

CVE-2023-2106 is a critical-severity (CVSS 9.8) CWE-521 vulnerability in calibreweb. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for calibreweb — see the affected versions and patch details below.

Weak Password Requirements in janeczku/calibre-web

Also known asGHSA-mhmp-m6g7-7c24PYSEC-2026-1233
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-2106.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs55th percentile — riskier than 55% of all scored CVEsHighest risk
0.00%0.42%0.83%1.25%0.4%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍calibreweb

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Weak Password Requirements in GitHub repository janeczku/calibre-web prior to 0.6.20.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIcalibreweball versions0.6.20pip install --upgrade 'calibreweb==0.6.20'

Affected Products

1 product · 1 configurations
Application
calibre-webjaneczku
< 0.6.20
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for calibreweb, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update calibreweb to 0.6.20 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-2106 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Weak Password Requirements in GitHub repository janeczku/calibre-web prior to 0.6.20.
O3 Security · Impact-Aware SCA

Is CVE-2023-2106 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2023-2106: calibreweb — Fixed in 0.6.20