NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2023-20873 — spring-boot-actuator-auto…

CRITICALFix: spring-projects/spring-boot@32444fe

CVE-2023-20873 is a critical-severity (CVSS 9.8) vulnerability in org.springframework.boot:spring-boot-actuator-autoconfigure. A fix is available for org.springframework.boot:spring-boot-actuator-autoconfigure — see the affected versions and patch details below.

Spring Boot Security Bypass with Wildcard Pattern Matching on Cloud Foundry

Also known asGHSA-g5h3-w546-pj7f
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-20873.

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs66th percentile — riskier than 66% of all scored CVEsHighest risk
0.00%0.54%1.08%1.62%0.4%1.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
☕org.springframework.boot:spring-boot-actuator-autoconfigure☕org.springframework.boot:spring-boot-actuator-autoconfigure☕org.springframework.boot:spring-boot-actuator-autoconfigure☕org.springframework.boot:spring-boot-actuator-autoconfigure

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

In Spring Boot versions 3.0.0 - 3.0.5, 2.7.0 - 2.7.10, and older unsupported versions, an application that is deployed to Cloud Foundry could be susceptible to a security bypass. Users of affected versions should apply the following mitigation: 3.0.x users should upgrade to 3.0.6+. 2.7.x users should upgrade to 2.7.11+. Users of older, unsupported versions should upgrade to 3.0.6+ or 2.7.11+.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.springframework.boot:spring-boot-actuator-autoconfigure≥ 3.0.0&&< 3.0.63.0.6org.springframework.boot:spring-boot-actuator-autoconfigure:3.0.6
☕Mavenorg.springframework.boot:spring-boot-actuator-autoconfigure≥ 2.7.0&&< 2.7.112.7.11org.springframework.boot:spring-boot-actuator-autoconfigure:2.7.11
☕Mavenorg.springframework.boot:spring-boot-actuator-autoconfigure≥ 2.6.0&&< 2.6.152.6.15org.springframework.boot:spring-boot-actuator-autoconfigure:2.6.15
☕Mavenorg.springframework.boot:spring-boot-actuator-autoconfigureall versions2.5.15org.springframework.boot:spring-boot-actuator-autoconfigure:2.5.15

Affected Products

1 product · 4 configurations
Application
spring bootvmware
≥ 3.0.0 && < 3.0.6
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.springframework.boot:spring-boot-actuator-autoconfigure, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.springframework.boot:spring-boot-actuator-autoconfigure to 3.0.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-20873 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

The following Red Hat products do not ship the affected software component and so are not affected: * Red Hat Enterprise Linux 8, 9 * Enterprise Application Platform 6, 7, 8, XP * Data Grid 7, 8 * Migration Toolkit for Runtimes * Red Hat Build of OptaPlanner * Red Hat Integration Camel-K * Red Hat AMQ Broker 7 * Red…

Workaround published by Red Hat
Disable Cloud Foundry actuator endpoints by setting 'management.cloudfoundry.enabled' to false.
Source: Red Hat security advisory for CVE-2023-20873 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat AMQ Streams 2.6.0spring-bootRHSA-2023:7678
RHINT Camel-Springboot 3.18.3.2spring-bootRHSA-2023:5147
RHINT Camel-Springboot 3.20.2spring-bootRHSA-2023:5148

Frequently Asked Questions

In Spring Boot versions 3.0.0 - 3.0.5, 2.7.0 - 2.7.10, and older unsupported versions, an application that is deployed to Cloud Foundry could be susceptible to a security bypass. Users of affected versions should apply the following mitigation: 3.0.x users should upgrade to 3.0.6+. 2.7.x users should upgrade to 2.7.11+. Users of older, unsupported versions should upgrade to 3.0.6+ or 2.7.11+.
O3 Security · Impact-Aware SCA

Is CVE-2023-20873 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2023-20873: spring-boot-actuator — Fixed in 3.0.6