NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

CVE-2023-1943 — kops

HIGH

CVE-2023-1943 is a high-severity (CVSS 8) CWE-250 vulnerability in k8s.io/kops. A fix is available for k8s.io/kops — see the affected versions and patch details below.

Privilege Escalation in kOps using GCE/GCP Provider in Gossip Mode

Also known asGHSA-8gwj-m6vh-2g6jGO-2023-2125
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-1943.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs48th percentile — riskier than 48% of all scored CVEsHighest risk
0.00%0.36%0.72%1.08%0.1%0.6%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐹k8s.io/kops🐹k8s.io/kops

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Privilege Escalation in kOps using GCE/GCP Provider in Gossip Mode.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐹Gok8s.io/kopsall versions1.25.4go get k8s.io/kops@v1.25.4
🐹Gok8s.io/kops≥ 1.26.0&&< 1.26.21.26.2go get k8s.io/kops@v1.26.2

Affected Products

1 product · 2 configurations
Application
operationskubernetes
≥ 1.26.0 && < 1.26.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for k8s.io/kops, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update k8s.io/kops to 1.25.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-1943 is resolved across your whole dependency graph.

  3. Workarounds

    Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.

Frequently Asked Questions

Privilege Escalation in kOps using GCE/GCP Provider in Gossip Mode.
O3 Security · Impact-Aware SCA

Is CVE-2023-1943 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2023-1943: kops PrivEsc — Fixed in 1.25.4