NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2023-1775 — mattermost-server

MEDIUM

CVE-2023-1775 is a medium-severity (CVSS 4.3) Information Exposure vulnerability in github.com/mattermost/mattermost-server. A fix is available for github.com/mattermost/mattermost-server — see the affected versions and patch details below.

Unsanitized events sent over Websocket to regular users in a High Availability environment

Also known asBIT-mattermost-2023-1775GHSA-8jhh-3jf2-pfwr
Published
Updated
Affected
5 pkgs
Patched
5 / 5
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-1775.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs46th percentile — riskier than 46% of all scored CVEsHighest risk
0.00%0.35%0.70%1.05%0.3%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

5 pkgs affected
🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost-server/v5🐹github.com/mattermost/mattermost-server/v6

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

When running in a High Availability configuration, Mattermost fails to sanitize some of the user_updated and post_deleted events broadcast to all users, leading to disclosure of sensitive information to some of the users with currently connected Websocket clients.

Issue Identifier: MMSA-2023-00138

Affected Packages

5 total 5 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/mattermost/mattermost-server≥ 3.3.0&&< 7.1.67.1.6go get github.com/mattermost/mattermost-server@v7.1.6
🐹Gogithub.com/mattermost/mattermost-server≥ 7.7.0&&< 7.7.27.7.2go get github.com/mattermost/mattermost-server@v7.7.2
🐹Gogithub.com/mattermost/mattermost-server≥ 7.1.0&&< 7.1.67.1.6go get github.com/mattermost/mattermost-server@v7.1.6
🐹Gogithub.com/mattermost/mattermost-server/v5≥ 5.0.0&&< 7.1.67.1.6go get github.com/mattermost/mattermost-server/v5@v7.1.6
🐹Gogithub.com/mattermost/mattermost-server/v6≥ 6.0.0&&< 7.1.67.1.6go get github.com/mattermost/mattermost-server/v6@v7.1.6

Affected Products

1 product · 2 configurations
Application
mattermost servermattermost
< 7.1.6
1 version
7.7.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/mattermost/mattermost-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/mattermost/mattermost-server to 7.1.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-1775 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

When running in a High Availability configuration, Mattermost fails to sanitize some of the `user_updated` and` post_deleted` events broadcast to all users, leading to disclosure of sensitive information to some of the users with currently connected Websocket clients. [Issue Identifier](https://mattermost.com/security-updates/): MMSA-2023-00138
O3 Security · Impact-Aware SCA

Is CVE-2023-1775 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2023-1775: mattermost-server — Fixed in 7.1.6