NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2023-1419 — debezium-connector-mysql

MEDIUMFix: debezium/debezium@58ef4f0

CVE-2023-1419 is a medium-severity (CVSS 5.9) CWE-233 vulnerability in io.debezium:debezium-connector-mysql. A fix is available for io.debezium:debezium-connector-mysql — see the affected versions and patch details below.

Debezium database connector has a script injection vulnerability

Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-1419.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs33th percentile — riskier than 33% of all scored CVEsHighest risk
0.00%0.29%0.59%0.89%0.2%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
☕io.debezium:debezium-connector-mysql☕io.debezium:debezium-connector-sqlserver☕io.debezium:debezium-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A script injection vulnerability was found in the Debezium database connector, where it does not properly sanitize some parameters. This flaw allows an attacker to send a malicious request to inject a parameter that may allow the viewing of unauthorized data.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenio.debezium:debezium-connector-mysqlall versions2.3.0.Alpha1io.debezium:debezium-connector-mysql:2.3.0.Alpha1
☕Mavenio.debezium:debezium-connector-sqlserverall versions2.3.0.Alpha1io.debezium:debezium-connector-sqlserver:2.3.0.Alpha1
☕Mavenio.debezium:debezium-coreall versions2.3.0.Alpha1io.debezium:debezium-core:2.3.0.Alpha1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.debezium:debezium-connector-mysql, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update io.debezium:debezium-connector-mysql to 2.3.0.Alpha1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-1419 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

A script injection vulnerability was found in the Debezium database connector, where it does not properly sanitize some parameters. This flaw allows an attacker to send a malicious request to inject a parameter that may allow the viewing of unauthorized data.
O3 Security · Impact-Aware SCA

Is CVE-2023-1419 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2023-1419: Fixed in 2.3.0.Alpha1 (Medium 5.9)