NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2023-1402 — moodle

MEDIUMFix: moodle/moodle@f0a557b

CVE-2023-1402 is a medium-severity (CVSS 4.3) Information Exposure vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

Moodle: course participation report shows roles the user should not see

Also known asBIT-moodle-2023-1402GHSA-vj5p-fp42-774p
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Oct 26, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-1402.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs54th percentile — riskier than 54% of all scored CVEsHighest risk
0.00%0.41%0.83%1.24%0.4%0.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

The course participation report required additional checks to prevent roles being displayed which the user did not have access to view.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodle≥ 4.1.0&&< 4.1.24.1.2composer require moodle/moodle:^4.1.2
🐘Packagistmoodle/moodle≥ 4.0.0&&< 4.0.74.0.7composer require moodle/moodle:^4.0.7
🐘Packagistmoodle/moodle≥ 3.11.0&&< 3.11.133.11.13composer require moodle/moodle:^3.11.13
🐘Packagistmoodle/moodleall versions3.9.20composer require moodle/moodle:^3.9.20

Affected Products

1 product · 8 configurations
Application
moodlemoodle
> 4.0.0 && < 4.0.7
5 versions
3.9.03.11.04.0.04.1.04.1.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moodle/moodle to 4.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-1402 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

The course participation report required additional checks to prevent roles being displayed which the user did not have access to view.
O3 Security · Impact-Aware SCA

Is CVE-2023-1402 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2023-1402: moodle — Fixed in 4.1.2