NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2023-1115 — pimcore

HIGHFix: pimcore/pimcore@c6368b7

CVE-2023-1115 is a high-severity (CVSS 7.6) Cross-site Scripting (XSS) vulnerability in pimcore/pimcore. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for pimcore/pimcore — see the affected versions and patch details below.

Cross-site Scripting (XSS) - Stored in pimcore/pimcore

Also known asGHSA-97cp-8873-v2gf
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 24, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-1115.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs45th percentile — riskier than 45% of all scored CVEsHighest risk
0.00%0.35%0.70%1.05%0.0%0.6%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘pimcore/pimcore

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Impact

An attacker can use XSS to send a malicious script to any user through Document Page Link Editable -> Advanced -> Attributes

Patches

Update to version 10.5.18 or apply this patch manually https://github.com/pimcore/pimcore/pull/14500.patch

Workarounds

Apply https://github.com/pimcore/pimcore/pull/14500.patch manually.

References

https://huntr.dev/bounties/cfa80332-e4cf-4d64-b3e5-e10298628d17/

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistpimcore/pimcoreall versions10.5.18composer require pimcore/pimcore:^10.5.18

Affected Products

1 product · 1 configurations
Application
pimcorepimcore
< 10.5.18
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pimcore/pimcore, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update pimcore/pimcore to 10.5.18 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-1115 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

### Impact An attacker can use XSS to send a malicious script to any user through Document Page Link Editable -> Advanced -> Attributes ### Patches Update to version 10.5.18 or apply this patch manually https://github.com/pimcore/pimcore/pull/14500.patch ### Workarounds Apply https://github.com/pimcore/pimcore/pull/14500.patch manually. ### References https://huntr.dev/bounties/cfa80332-e4cf-4d64-b3e5-e10298628d17/
O3 Security · Impact-Aware SCA

Is CVE-2023-1115 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2023-1115: pimcore XSS — Fixed in 10.5.18