CVE-2023-0871 is a medium-severity (CVSS 5.4) XML External Entity (XXE) vulnerability in org.opennms.core:org.opennms.core.xml. A fix is available for org.opennms.core:org.opennms.core.xml — see the affected versions and patch details below.
An XML External Entity injection vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.opennms.core:org.opennms.core.xmlReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
XXE injection in /rtc/post/ endpoint in OpenMNS Horizon 31.0.8 and versions earlier than 32.0.2 on multiple platforms is vulnerable to XML external entity (XXE) injection, which can be used for instance to force Horizon to make arbitrary HTTP requests to internal and external services. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Erik Wynter and Moshe Apelbaum for reporting this issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.opennms.core:org.opennms.core.xml | ≥ 31.0.8&&< 32.0.2 | 32.0.2org.opennms.core:org.opennms.core.xml:32.0.2 |
Affected Products
horizonopennmsmeridianopennmsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.opennms.core:org.opennms.core.xml, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.opennms.core:org.opennms.core.xml to 32.0.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-0871 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2023-0871 in your dependencies?
Find it across Maven, including transitive dependencies.