NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
CRITICAL severity

CVE-2023-0106 — memos

CRITICALFix: usememos/memos@0f8ce3d

CVE-2023-0106 is a critical-severity (CVSS 9) Cross-site Scripting (XSS) vulnerability in github.com/usememos/memos. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for github.com/usememos/memos — see the affected versions and patch details below.

Cross-site Scripting (XSS) - Stored in usememos/memos

Also known asGHSA-8686-4cr3-76wj
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-0106.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk+0.02%
Lower risk than most CVEs52th percentile — riskier than 52% of all scored CVEsHighest risk
0.00%0.39%0.78%1.16%0.3%0.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/usememos/memos

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos prior to 0.10.0.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/usememos/memosall versions0.10.0go get github.com/usememos/memos@v0.10.0

Affected Products

1 product · 1 configurations
Application
memosusememos
< 0.10.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/usememos/memos, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/usememos/memos to 0.10.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-0106 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos prior to 0.10.0.
O3 Security · Impact-Aware SCA

Is CVE-2023-0106 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2023-0106: memos XSS — Fixed in 0.10.0