CVE-2022-4899 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in zstd. A fix is available for zstd — see the affected versions and patch details below.
zstd vulnerable to buffer overrun
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-4899.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
zstd📦github.com/facebook/zstdReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI, SwiftURL packages — download data is not available via public APIs for these ecosystems.
Description
A vulnerability was found in zstd v1.4.10, where an attacker can supply an empty string as an argument to the command line tool to cause buffer overrun.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | zstd | all versions | 1.5.4.0pip install --upgrade 'zstd==1.5.4.0' |
| 📦SwiftURL | github.com/facebook/zstd | all versions | 1.5.4 |
Affected Products
zstandardfacebookDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for zstd, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update zstd to 1.5.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-4899 is resolved across your whole dependency graph.
Workarounds
Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
The vulnerability in the zstd command-line utility is rated as Moderate Severity because it involves an Incorrect Calculation of Buffer Size (CWE-400) within the mallocAndJoin2Dir function in programs/util.c. A remote attacker can exploit this flaw by providing an input, specifically an empty string, which causes a…
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat AMQ Streams 2.7.0 | see advisory | RHSA-2024:3527 |
| Red Hat Enterprise Linux 8 | mysql:8.0-8090020240126173013.a75119d5 | RHSA-2024:0894 |
| Red Hat Enterprise Linux 9 | mysql-0:8.0.36-1.el9_3 | RHSA-2024:1141 |
| Red Hat Software Collections for Red Hat Enterprise Linux 7 | rh-mysql80-mysql-0:8.0.36-1.el7 | RHSA-2024:2619 |
Frequently Asked Questions
Is CVE-2022-4899 in your dependencies?
Find it across PyPI, SwiftURL, including transitive dependencies.