NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

CVE-2022-4809 — memos

HIGHFix: usememos/memos@3556ae4

CVE-2022-4809 is a high-severity (CVSS 8.3) CWE-284 vulnerability in github.com/usememos/memos. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for github.com/usememos/memos — see the affected versions and patch details below.

Improper Access Control in usememos/memos

Also known asGHSA-6w5w-wx8w-2cq9GO-2022-1252
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-4809.

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs62th percentile — riskier than 62% of all scored CVEsHighest risk
0.00%0.49%0.98%1.47%0.3%1.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/usememos/memos

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

usememos/memos 0.9.0 and prior is vulnerable to full account takeover via changing user name, email address, and display name.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/usememos/memosall versions0.9.1go get github.com/usememos/memos@v0.9.1

Affected Products

1 product · 1 configurations
Application
memosusememos
< 0.9.1
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/usememos/memos, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/usememos/memos to 0.9.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-4809 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

usememos/memos 0.9.0 and prior is vulnerable to full account takeover via changing user name, email address, and display name.
O3 Security · Impact-Aware SCA

Is CVE-2022-4809 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2022-4809: memos — Fixed in 0.9.1