CVE-2022-47411 — fp-newsletter
CRITICALCVE-2022-47411 is a critical-severity (CVSS 9.1) Information Exposure vulnerability in fixpunkt/fp-newsletter. A fix is available for fixpunkt/fp-newsletter — see the affected versions and patch details below.
"Newsletter subscriber management" (fp_newsletter) TYPO3 extension leaks subscriber data
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-47411.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
fixpunkt/fp-newsletter🐘fixpunkt/fp-newsletter🐘fixpunkt/fp-newsletterReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in the fp_newsletter (aka Newsletter subscriber management) extension before 1.1.1, 1.2.0, 2.x before 2.1.2, 2.2.1 through 2.4.0, and 3.x before 3.2.6 for TYPO3. Data about subscribers may be obtained via unsubscribeAction operations.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | fixpunkt/fp-newsletter | all versions | 1.1.1composer require fixpunkt/fp-newsletter:^1.1.1 |
| 🐘Packagist | fixpunkt/fp-newsletter | ≥ 1.2.0&&< 2.1.2 | 2.1.2composer require fixpunkt/fp-newsletter:^2.1.2 |
| 🐘Packagist | fixpunkt/fp-newsletter | ≥ 3.0.0&&< 3.2.6 | 3.2.6composer require fixpunkt/fp-newsletter:^3.2.6 |
Affected Products
fp newsletterfp_newsletter_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for fixpunkt/fp-newsletter, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update fixpunkt/fp-newsletter to 1.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-47411 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Frequently Asked Questions
Is CVE-2022-47411 in your dependencies?
Find it across Packagist, including transitive dependencies.