CVE-2022-47407 is a medium-severity (CVSS 6.5) CWE-284 vulnerability in fixpunkt/fp-masterquiz. A fix is available for fixpunkt/fp-masterquiz — see the affected versions and patch details below.
TYPO3-EXT-SA-2022-018: Multiple vulnerabilities in extension "Master-Quiz" (fp_masterquiz)
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-47407.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
fixpunkt/fp-masterquiz🐘fixpunkt/fp-masterquizReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in the fp_masterquiz (aka Master-Quiz) extension before 2.2.1, and 3.x before 3.5.1, for TYPO3. An attacker can continue the quiz of a different user. In doing so, the attacker can view that user's answers and modify those answers.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | fixpunkt/fp-masterquiz | ≥ 3.0.0&&< 3.5.2 | 3.5.2composer require fixpunkt/fp-masterquiz:^3.5.2 |
| 🐘Packagist | fixpunkt/fp-masterquiz | all versions | 2.2.1composer require fixpunkt/fp-masterquiz:^2.2.1 |
Affected Products
master-quizmaster-quiz_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for fixpunkt/fp-masterquiz, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update fixpunkt/fp-masterquiz to 3.5.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-47407 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2022-47407 in your dependencies?
Find it across Packagist, including transitive dependencies.