CVE-2022-4643 is a medium-severity (CVSS 6.3) OS Command Injection vulnerability in github.com/sajari/docconv. A fix is available for github.com/sajari/docconv — see the affected versions and patch details below.
docconv pdf_ocr.go ConvertPDFImages os command injection
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/sajari/docconv🐹code.sajari.com/docconvReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
A vulnerability was found in docconv up to 1.2.0. It has been declared as critical. This vulnerability affects the function ConvertPDFImages of the file pdf_ocr.go. The manipulation of the argument path leads to os command injection. The attack can be initiated remotely. Upgrading to version 1.2.1 is able to address this issue. The name of the patch is b19021ade3d0b71c89d35cb00eb9e589a121faa5. It is recommended to upgrade the affected component. VDB-216502 is the identifier assigned to this vulnerability.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/sajari/docconv | all versions | 1.2.1go get github.com/sajari/docconv@v1.2.1 |
| 🐹Go | code.sajari.com/docconv | ≥ 1.1.0&&< 1.3.5 | 1.3.5go get code.sajari.com/docconv@v1.3.5 |
Affected Products
docconvsearchDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/sajari/docconv, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/sajari/docconv to 1.2.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-4643 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2022-4643 in your dependencies?
Find it across Go, including transitive dependencies.