NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2022-45693 — jettison

HIGH

CVE-2022-45693 is a high-severity (CVSS 7.5) Out-of-bounds Write vulnerability in org.codehaus.jettison:jettison. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.codehaus.jettison:jettison — see the affected versions and patch details below.

Jettison Out-of-bounds Write vulnerability

Also known asGHSA-grr4-wv38-f68w
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-45693.

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk+0.05%
Lower risk than most CVEs74th percentile — riskier than 74% of all scored CVEsHighest risk
0.00%0.66%1.33%1.99%0.1%1.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.codehaus.jettison:jettison

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Jettison before v1.5.2 was discovered to contain a stack overflow via the map parameter. This vulnerability allows attackers to cause a Denial of Service (DoS) via a crafted string.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.codehaus.jettison:jettisonall versions1.5.2org.codehaus.jettison:jettison:1.5.2

Affected Products

2 products · 3 configurations
OS
debian linuxdebian
2 versions
10.011.0
Application
jettisonjettison_project
< 1.5.2
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.codehaus.jettison:jettison, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.codehaus.jettison:jettison to 1.5.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-45693 is resolved across your whole dependency graph.

  3. Workarounds

    Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

Red Hat has determined the impact of this flaw to be Moderate; a successful attack using this flaw would require the processing of untrusted, unsanitized, or unrestricted user inputs, which runs counter to established Red Hat security practices.

ProductFixed inAdvisory
MTA-6.2-RHEL-8mta/mta-rhel8-operator:6.2.2-3RHSA-2024:1027
OCP-Tools-4.12-RHEL-8jenkins-2-plugins-0:4.12.1686649756-1.el8RHSA-2023:3610
Red Hat JBoss Enterprise Application Platform 7.1 EUS for RHEL 7eap7-apache-cxf-0:3.1.16-4.redhat_00003.1.ep7.el7RHSA-2025:1746
Red Hat JBoss Enterprise Application Platform 7.3 EUS for RHEL 7eap7-jackson-modules-java8-0:2.10.4-2.redhat_00004.1.el7eapRHSA-2025:1747
Red Hat JBoss Enterprise Application Platform 7.4.9org.codehaus.jettison/jettison:1.5.2.redhat-00002RHSA-2023:0556
Red Hat JBoss Enterprise Application Platform 7.4 for RHEL 8eap7-jettison-0:1.5.2-1.redhat_00002.1.el8eapRHSA-2023:0553
Red Hat JBoss Enterprise Application Platform 7.4 for RHEL 9eap7-jettison-0:1.5.2-1.redhat_00002.1.el9eapRHSA-2023:0554
Red Hat JBoss Enterprise Application Platform 7.4 on RHEL 7eap7-jettison-0:1.5.2-1.redhat_00002.1.el7eapRHSA-2023:0552

Frequently Asked Questions

Jettison before v1.5.2 was discovered to contain a stack overflow via the map parameter. This vulnerability allows attackers to cause a Denial of Service (DoS) via a crafted string.
O3 Security · Impact-Aware SCA

Is CVE-2022-45693 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-45693: jettison DoS — Fixed in 1.5.2