NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2022-45402 — apache-airflow

MEDIUMFix: apache/airflow#27576

CVE-2022-45402 is a medium-severity (CVSS 6.1) Open Redirect vulnerability in apache-airflow. EPSS puts its 30-day exploitation probability at 81.8% (100th percentile). A fix is available for apache-airflow — see the affected versions and patch details below.

Apache Airflow: Open redirect during login

Also known asBIT-airflow-2022-45402GHSA-rg94-84xj-7gq3PYSEC-2022-42984
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-45402.

EPSS Exploitation Probability

via FIRST.org ↗
81.8%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
0.00%33.3%66.7%100.0%5.8%81.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍apache-airflow

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

In Apache Airflow versions prior to 2.4.3, there was an open redirect in the webserver's /login endpoint.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIapache-airflowall versions2.4.3pip install --upgrade 'apache-airflow==2.4.3'

Affected Products

1 product · 1 configurations
Application
airflowapache
< 2.4.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for apache-airflow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update apache-airflow to 2.4.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-45402 is resolved across your whole dependency graph.

  3. Workarounds

    Stop reflecting attacker-controlled destinations: resolve every redirect target against an allowlist of paths or hosts you own, prefer a server-side key over a full URL in the request, and reject absolute URLs entirely where the flow only ever needs a relative one.

Frequently Asked Questions

In Apache Airflow versions prior to 2.4.3, there was an open redirect in the webserver's `/login` endpoint.
O3 Security · Impact-Aware SCA

Is CVE-2022-45402 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2022-45402: apache-airflow — Fixed in 2.4.3