CVE-2022-4521 is a low-severity (CVSS 3.5) Cross-site Scripting (XSS) vulnerability in org.wso2.carbon.registry:carbon-registry. A fix is available for org.wso2.carbon.registry:carbon-registry — see the affected versions and patch details below.
WSO2 carbon-registry Request Parameter cross site scripting
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.wso2.carbon.registry:carbon-registryReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
A vulnerability classified as problematic has been found in WSO2 carbon-registry up to 4.8.6. This affects an unknown part of the component Request Parameter Handler. The manipulation of the argument parentPath/path/username/path/profile_menu leads to cross site scripting. It is possible to initiate the attack remotely. Upgrading to version 4.8.7 is able to address this issue. The name of the patch is 9f967abfde9317bee2cda469dbc09b57d539f2cc. It is recommended to upgrade the affected component. The identifier VDB-215901 was assigned to this vulnerability.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.wso2.carbon.registry:carbon-registry | all versions | 4.8.7org.wso2.carbon.registry:carbon-registry:4.8.7 |
Affected Products
carbon-registrywso2Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.wso2.carbon.registry:carbon-registry, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.wso2.carbon.registry:carbon-registry to 4.8.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-4521 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2022-4521 in your dependencies?
Find it across Maven, including transitive dependencies.