NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2022-45129 — payara

HIGHFix: payara/Payara@cccdfdd

CVE-2022-45129 is a high-severity (CVSS 7.5) CWE-552 vulnerability in fish.payara.distributions:payara. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for fish.payara.distributions:payara — see the affected versions and patch details below.

Payara, when deployed to the root context, allows attackers to visit META-INF and WEB-INF

Also known asGHSA-q35w-85pq-rv3x
Published
Updated
Affected
3 pkgs
Patched
2 / 3
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-45129.

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs74th percentile — riskier than 74% of all scored CVEsHighest risk
0.00%0.67%1.34%2.01%0.4%1.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
☕fish.payara.distributions:payara☕fish.payara.distributions:payara☕fish.payara.distributions:payara

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Payara before 2022-11-04, when deployed to the root context, allows attackers to visit META-INF and WEB-INF, a different vulnerability than CVE-2022-37422. This affects Payara Platform Community before 4.1.2.191.38, 5.x before 5.2022.4, and 6.x before 6.2022.1, and Payara Platform Enterprise before 5.45.0.

Affected Packages

3 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenfish.payara.distributions:payara≥ 6.2021.1.Alpha1&&< 6.2022.26.2022.2fish.payara.distributions:payara:6.2022.2
☕Mavenfish.payara.distributions:payara≥ 5.0.0.Alpha1&&< 5.2022.55.2022.5fish.payara.distributions:payara:5.2022.5
☕Mavenfish.payara.distributions:payaraall versionsNo fix

Affected Products

1 product · 4 configurations
Application
payarapayara
≥ 6.0.0 && < 6.2022.1
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for fish.payara.distributions:payara, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update fish.payara.distributions:payara to 6.2022.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-45129 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Payara before 2022-11-04, when deployed to the root context, allows attackers to visit META-INF and WEB-INF, a different vulnerability than CVE-2022-37422. This affects Payara Platform Community before 4.1.2.191.38, 5.x before 5.2022.4, and 6.x before 6.2022.1, and Payara Platform Enterprise before 5.45.0.
O3 Security · Impact-Aware SCA

Is CVE-2022-45129 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-45129: payara — Fixed in 6.2022.2