NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
CRITICAL severity

CVE-2022-44797 — btcd

CRITICALFix: btcsuite/btcd#1896

CVE-2022-44797 is a critical-severity (CVSS 9.8) vulnerability in github.com/btcsuite/btcd. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for github.com/btcsuite/btcd — see the affected versions and patch details below.

btcd mishandles witness size checking

Also known asGHSA-2chg-86hq-7w38GO-2022-1098
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-44797.

EPSS Exploitation Probability

via FIRST.org ↗
1.6%probability of exploitation in next 30 days
Lower Risk+0.26%
Lower risk than most CVEs75th percentile — riskier than 75% of all scored CVEsHighest risk
0.19%0.81%1.44%2.06%0.7%1.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐹github.com/btcsuite/btcd🐹github.com/lightningnetwork/lnd

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

btcd before 0.23.2, as used in Lightning Labs lnd before 0.15.2-beta and other Bitcoin-related products, mishandles witness size checking.

Specific Go Packages Affected

github.com/btcsuite/btcd/wire

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/btcsuite/btcdall versions0.23.2go get github.com/btcsuite/btcd@v0.23.2
🐹Gogithub.com/lightningnetwork/lndall versions0.15.2-betago get github.com/lightningnetwork/lnd@v0.15.2-beta

Affected Products

1 product · 1 configurations
Application
btcdbtcd_project
< 0.23.2
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/btcsuite/btcd, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/btcsuite/btcd to 0.23.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-44797 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

btcd before 0.23.2, as used in Lightning Labs lnd before 0.15.2-beta and other Bitcoin-related products, mishandles witness size checking. ### Specific Go Packages Affected github.com/btcsuite/btcd/wire
O3 Security · Impact-Aware SCA

Is CVE-2022-44797 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2022-44797: btcd — Fixed in 0.23.2