CVE-2022-44729 is a high-severity (CVSS 7.1) Server-Side Request Forgery (SSRF) vulnerability in org.apache.xmlgraphics:batik-bridge. A fix is available for org.apache.xmlgraphics:batik-bridge — see the affected versions and patch details below.
Apache XML Graphics Batik Server-Side Request Forgery vulnerability
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-44729.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.xmlgraphics:batik-bridge☕org.apache.xmlgraphics:batik-svgrasterizer☕org.apache.xmlgraphics:batik-transcoderReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Server-Side Request Forgery (SSRF) vulnerability in Apache Software Foundation Apache XML Graphics Batik.This issue affects Apache XML Graphics Batik: 1.16.
On version 1.16, a malicious SVG could trigger loading external resources by default, causing resource consumption or in some cases even information disclosure. Users are recommended to upgrade to version 1.17 or later.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.xmlgraphics:batik-bridge | ≥ 1.0&&< 1.17 | 1.17org.apache.xmlgraphics:batik-bridge:1.17 |
| ☕Maven | org.apache.xmlgraphics:batik-svgrasterizer | ≥ 1.0&&< 1.17 | 1.17org.apache.xmlgraphics:batik-svgrasterizer:1.17 |
| ☕Maven | org.apache.xmlgraphics:batik-transcoder | ≥ 1.0&&< 1.17 | 1.17org.apache.xmlgraphics:batik-transcoder:1.17 |
Affected Products
xml graphics batikapachedebian linuxdebianDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.xmlgraphics:batik-bridge, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.xmlgraphics:batik-bridge to 1.17 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-44729 is resolved across your whole dependency graph.
Workarounds
Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| RHINT Camel-Springboot 4.0.0 | batik | RHSA-2023:5441 |
| RHPAM 7.13.5 async | batik | RHSA-2024:1353 |
Frequently Asked Questions
Is CVE-2022-44729 in your dependencies?
Find it across Maven, including transitive dependencies.