CVE-2022-44303 — resque-scheduler
MEDIUMCVE-2022-44303 is a medium-severity (CVSS 6.3) Cross-site Scripting (XSS) vulnerability in resque-scheduler. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for resque-scheduler — see the affected versions and patch details below.
Resque Scheduler Reflected XSS In Delayed Jobs View
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-44303.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
resque-schedulerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Resque Scheduler version 1.27.4 and above are affected by a cross-site scripting vulnerability. A remote attacker can inject javascript code to the "{schedule_job}" or "args" parameter in /resque/delayed/jobs/{schedule_job}?args={args_id} to execute javascript at client side.
Patches
Fixed in v4.10.2
Workarounds
No known workarounds at this time. It is recommended to not click on 3rd party or untrusted links to the resque-web interface until you have patched your application.
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | resque-scheduler | ≥ 1.27.4&&< 4.10.2 | 4.10.2bundle update resque-scheduler --conservative |
Affected Products
resque-schedulerresque-scheduler_projectResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for resque-scheduler, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update resque-scheduler to 4.10.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-44303 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2022-44303 in your dependencies?
Find it across RubyGems, including transitive dependencies.