CVE-2022-44262 is a critical-severity (CVSS 9.8) Code Injection vulnerability in org.ff4j:ff4j-core. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.ff4j:ff4j-core — see the affected versions and patch details below.
ff4j is vulnerable to Remote Code Execution (RCE)
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-44262.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.ff4j:ff4j-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
ff4j 1.8.1 is vulnerable to Remote Code Execution (RCE). This issue has been patched in version 1.9.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.ff4j:ff4j-core | ≥ 1.8.1&&< 1.9 | 1.9org.ff4j:ff4j-core:1.9 |
Affected Products
ff4jff4jResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.ff4j:ff4j-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.ff4j:ff4j-core to 1.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-44262 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2022-44262 in your dependencies?
Find it across Maven, including transitive dependencies.