CVE-2022-43984 is a high-severity (CVSS 8.2) Cross-site Scripting (XSS) vulnerability in spatie/browsershot. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for spatie/browsershot — see the affected versions and patch details below.
Browsershot 3.57.3 - Server Side XSS to LFR via HTML
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-43984.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
spatie/browsershotReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Browsershot version 3.57.3 allows an external attacker to remotely obtain arbitrary local files. This is possible because the application does not validate that the JS content imported from an external source passed to the Browsershot::html method does not contain URLs that use the file:// protocol.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | spatie/browsershot | all versions | 3.57.4composer require spatie/browsershot:^3.57.4 |
Affected Products
browsershotspatieResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for spatie/browsershot, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update spatie/browsershot to 3.57.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-43984 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2022-43984 in your dependencies?
Find it across Packagist, including transitive dependencies.