CVE-2022-43756 is a medium-severity (CVSS 5.9) CWE-74 vulnerability in github.com/rancher/wrangler. A fix is available for github.com/rancher/wrangler — see the affected versions and patch details below.
Rancher/Wrangler: Denial of service when processing Git credentials
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-43756.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/rancher/wrangler🐹github.com/rancher/wrangler🐹github.com/rancher/wrangler🐹github.com/rancher/wranglerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
A denial of services (DoS) vulnerability was discovered in Wrangler Git package affecting versions up to and including v1.0.0.
Specially crafted Git credentials can result in a denial of service (DoS) attack on an application that uses Wrangler due to the exhaustion of the available memory and CPU resources. This is caused by a lack of input validation of Git credentials before they are used, which may lead to a denial of service in some cases. This issue can be triggered when accessing both private and public Git repositories.
Workarounds
A workaround is to sanitize input passed to the Git package to remove potential unsafe and ambiguous characters. Otherwise, the best course of action is to update to a patched Wrangler version.
Patches
Patched versions include v1.0.1 and later and the backported tags - v0.7.4-security1, v0.8.5-security1 and v0.8.11.
For more information
If you have any questions or comments about this advisory:
- Reach out to SUSE Rancher Security team for security related inquiries.
- Open an issue in Rancher or Wrangler repository.
- Verify our support matrix and product support lifecycle.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/rancher/wrangler | all versions | 0.7.4-security1go get github.com/rancher/wrangler@v0.7.4-security1 |
| 🐹Go | github.com/rancher/wrangler | ≥ 0.8.0&&< 0.8.5-security1 | 0.8.5-security1go get github.com/rancher/wrangler@v0.8.5-security1 |
| 🐹Go | github.com/rancher/wrangler | ≥ 1.0.0&&< 1.0.1 | 1.0.1go get github.com/rancher/wrangler@v1.0.1 |
| 🐹Go | github.com/rancher/wrangler | ≥ 0.8.6&&< 0.8.11 | 0.8.11go get github.com/rancher/wrangler@v0.8.11 |
Affected Products
wranglersuseDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/rancher/wrangler, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/rancher/wrangler to 0.7.4-security1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-43756 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2022-43756 in your dependencies?
Find it across Go, including transitive dependencies.