CVE-2022-41930 is a high-severity (CVSS 7.5) CWE-862 vulnerability in org.xwiki.platform:xwiki-platform-user-profile-ui. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.xwiki.platform:xwiki-platform-user-profile-ui — see the affected versions and patch details below.
org.xwiki.platform:xwiki-platform-user-profile-ui missing authorization to enable or disable users
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-41930.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.xwiki.platform:xwiki-platform-user-profile-ui☕org.xwiki.platform:xwiki-platform-user-profile-uiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Any user (logged in or not) with access to the page XWiki.XWikiUserProfileSheet can enable or disable any user profile. This might allow to a disabled user to re-enable themselves, or to an attacker to disable any user of the wiki.
Patches
The problem has been patched in XWiki 13.10.7, 14.5RC1 and 14.4.2.
Workarounds
The problem can be patched immediately by editing the page XWiki.XWikiUserProfileSheet in the wiki and by performing the changes contained in https://github.com/xwiki/xwiki-platform/commit/5be1cc0adf917bf10899c47723fa451e950271fa.
References
- https://github.com/xwiki/xwiki-platform/commit/5be1cc0adf917bf10899c47723fa451e950271fa
- https://jira.xwiki.org/browse/XWIKI-19792
For more information
If you have any questions or comments about this advisory:
- Open an issue in JIRA
- Email us at security ML
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.xwiki.platform:xwiki-platform-user-profile-ui | ≥ 12.4&&< 13.10.7 | 13.10.7org.xwiki.platform:xwiki-platform-user-profile-ui:13.10.7 |
| ☕Maven | org.xwiki.platform:xwiki-platform-user-profile-ui | ≥ 14.0.0&&< 14.4.2 | 14.4.2org.xwiki.platform:xwiki-platform-user-profile-ui:14.4.2 |
Affected Products
xwikixwikiResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.xwiki.platform:xwiki-platform-user-profile-ui, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.xwiki.platform:xwiki-platform-user-profile-ui to 13.10.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-41930 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2022-41930 in your dependencies?
Find it across Maven, including transitive dependencies.