CVE-2022-41924 — tailscale.com
CRITICALCVE-2022-41924 is a critical-severity (CVSS 9.6) CWE-346 vulnerability in tailscale.com. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for tailscale.com — see the affected versions and patch details below.
Tailscale Windows daemon is vulnerable to RCE via CSRF
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-41924.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
tailscale.comReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
A vulnerability identified in the Tailscale Windows client allows a malicious website to reconfigure the Tailscale daemon tailscaled, which can then be used to remotely execute code.
Affected platforms: Windows Patched Tailscale client versions: v1.32.3 or later, v1.33.257 or later (unstable)
What happened?
In the Tailscale Windows client, the local API was bound to a local TCP socket, and communicated with the Windows client GUI in cleartext with no Host header verification. This allowed an attacker-controlled website visited by the node to rebind DNS to an attacker-controlled DNS server, and then make local API requests in the client, including changing the coordination server to an attacker-controlled coordination server.
Who is affected?
All Windows clients prior to version v.1.32.3 are affected.
What should I do?
If you are running Tailscale on Windows, upgrade to v1.32.3 or later to remediate the issue.
What is the impact?
An attacker-controlled coordination server can send malicious URL responses to the client, including pushing executables or installing an SMB share. These allow the attacker to remotely execute code on the node.
Reviewing all logs confirms this vulnerability was not triggered or exploited.
Credits
We would like to thank Emily Trau and Jamie McClymont (CyberCX) for reporting this issue. Further detail is available in their blog post.
References
For more information
If you have any questions or comments about this advisory, contact Tailscale support.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | tailscale.com | all versions | 1.32.3go get tailscale.com@v1.32.3 |
Affected Products
tailscaletailscaleResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tailscale.com, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update tailscale.com to 1.32.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-41924 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2022-41924 in your dependencies?
Find it across Go, including transitive dependencies.