NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
CRITICAL severity

CVE-2022-41912 — saml

CRITICALFix: crewjam/saml@aee3fb1

CVE-2022-41912 is a critical-severity (CVSS 9.1) Improper Authentication vulnerability in github.com/crewjam/saml. A fix is available for github.com/crewjam/saml — see the affected versions and patch details below.

crewjam/saml go library is vulnerable to signature bypass via multiple Assertion elements

Also known asGHSA-j2jp-wvqg-wc2gGO-2022-1129
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-41912.

EPSS Exploitation Probability

via FIRST.org ↗
2.3%probability of exploitation in next 30 days
Lower Risk+0.01%
Lower risk than most CVEs84th percentile — riskier than 84% of all scored CVEsHighest risk
0.00%0.98%1.96%2.95%0.3%2.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/crewjam/saml

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Impact

The crewjam/saml go library is vulnerable to an authentication bypass when processing SAML responses containing multiple Assertion elements.

Patches

This issue has been corrected in version 0.4.9.

Credit

This issue was reported by Felix Wilhelm from Google Project Zero.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/crewjam/samlall versions0.4.9go get github.com/crewjam/saml@v0.4.9

Affected Products

1 product · 1 configurations
Application
samlsaml_project
< 0.4.9
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/crewjam/saml, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/crewjam/saml to 0.4.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-41912 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatCritical

Whilst the Red Hat Advanced Cluster Management for Kubernetes (RHACM) acm-grafana container include the vulnerable underscore library, the access to it is protected by OpenShift OAuth. Therefore the impact by this flaw is reduced from Critical to Important. The OCP grafana-container includes the vulnerable underscore…

ProductFixed inAdvisory
Red Hat Ceph Storage 6.1rhceph/rhceph-6-dashboard-rhel9:6-75RHSA-2023:3642
Red Hat OpenShift Container Platform 4.10openshift4/ose-grafana:v4.10.0-202301040925.p0.gca476d4.assembly.streamRHSA-2023:0032
Red Hat OpenShift Container Platform 4.11openshift4/ose-grafana:v4.11.0-202212190555.p0.gbc05ec1.assembly.streamRHSA-2022:9108
Red Hat OpenShift Container Platform 4.8openshift4/ose-grafana:v4.8.0-202301100925.p0.g7156d02.assembly.streamRHSA-2023:0237
Red Hat OpenShift Container Platform 4.9openshift4/ose-grafana:v4.9.0-202301301454.p0.g06135eb.assembly.streamRHSA-2023:0574

Frequently Asked Questions

### Impact The crewjam/saml go library is vulnerable to an authentication bypass when processing SAML responses containing multiple Assertion elements. ### Patches This issue has been corrected in version 0.4.9. ### Credit This issue was reported by Felix Wilhelm from Google Project Zero.
O3 Security · Impact-Aware SCA

Is CVE-2022-41912 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2022-41912: saml Auth Bypass — Fixed in 0.4.9