CVE-2022-41323 is a high-severity (CVSS 7.5) CWE-1333 vulnerability in django. A fix is available for django — see the affected versions and patch details below.
Django denial-of-service vulnerability in internationalized URLs
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-41323.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
django🐍django🐍djangoReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
In Django 3.2 before 3.2.16, 4.0 before 4.0.8, and 4.1 before 4.1.2, internationalized URLs were subject to a potential denial of service attack via the locale parameter, which is treated as a regular expression.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | django | ≥ 3.2&&< 3.2.16 | 3.2.16pip install --upgrade 'django==3.2.16' |
| 🐍PyPI | django | ≥ 4.0&&< 4.0.8 | 4.0.8pip install --upgrade 'django==4.0.8' |
| 🐍PyPI | django | ≥ 4.1&&< 4.1.2 | 4.1.2pip install --upgrade 'django==4.1.2' |
Affected Products
djangodjangoprojectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for django, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update django to 3.2.16 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-41323 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Satellite 6.13 for RHEL 8 | python-django-0:3.2.18-1.el8pc | RHSA-2023:2097 |
| RHUI 4 for RHEL 8 | python-django-0:3.2.16-1.0.1.el8ui | RHSA-2023:0742 |
Frequently Asked Questions
Is CVE-2022-41323 in your dependencies?
Find it across PyPI, including transitive dependencies.