NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2022-4116 — quarkus-vertx-http-deploy…

CRITICAL

CVE-2022-4116 is a critical-severity (CVSS 9.8) remote code execution vulnerability in io.quarkus:quarkus-vertx-http-deployment. EPSS puts its 30-day exploitation probability at 32.5% (98th percentile). A fix is available for io.quarkus:quarkus-vertx-http-deployment — see the affected versions and patch details below.

Code injection in quarkus dev ui config editor

Also known asGHSA-g56w-cwg4-hxx9
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-4116.

EPSS Exploitation Probability

via FIRST.org ↗
32.5%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs98th percentile — riskier than 98% of all scored CVEsHighest risk
0.00%13.8%27.6%41.4%2.9%32.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕io.quarkus:quarkus-vertx-http-deployment☕io.quarkus:quarkus-vertx-http-deployment

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A vulnerability was found in quarkus. This security flaw happens in Dev UI Config Editor which is vulnerable to drive-by localhost attacks leading to remote code execution.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenio.quarkus:quarkus-vertx-http-deployment≥ 2.14.0&&< 2.14.2.Final2.14.2.Finalio.quarkus:quarkus-vertx-http-deployment:2.14.2.Final
☕Mavenio.quarkus:quarkus-vertx-http-deploymentall versions2.13.5.Finalio.quarkus:quarkus-vertx-http-deployment:2.13.5.Final

Affected Products

2 products · 3 configurations
Application
quarkusquarkus
≥ 2.14.0 && < 2.14.2
range
Application
build of quarkusredhat
all

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.quarkus:quarkus-vertx-http-deployment, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update io.quarkus:quarkus-vertx-http-deployment to 2.14.2.Final or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-4116 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
ProductFixed inAdvisory
Red Hat build of Quarkus 2.13.5see advisoryRHSA-2022:9023
Red Hat build of Quarkus Platform 2.7.6.SP3quarkus_dev_uiRHSA-2022:8957

Frequently Asked Questions

A vulnerability was found in quarkus. This security flaw happens in Dev UI Config Editor which is vulnerable to drive-by localhost attacks leading to remote code execution.
O3 Security · Impact-Aware SCA

Is CVE-2022-4116 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-4116: quarkus-vertx-http — Fixed in 2.14.2.Final