CVE-2022-40898 — wheel
HIGHCVE-2022-40898 is a high-severity (CVSS 7.5) Improper Input Validation vulnerability in wheel. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for wheel — see the affected versions and patch details below.
pypa/wheel vulnerable to Regular Expression denial of service (ReDoS)
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-40898.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
wheelReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Python Packaging Authority (PyPA) Wheel is a reference implementation of the Python wheel packaging standard. Wheel 0.37.1 and earlier are vulnerable to a Regular Expression denial of service via attacker controlled input to the wheel cli. The vulnerable regex is used to verify the validity of Wheel file names. This has been patched in version 0.38.1.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | wheel | all versions | 0.38.1pip install --upgrade 'wheel==0.38.1' |
Affected Products
wheelwheel_projectResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for wheel, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update wheel to 0.38.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-40898 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 9 | rhc-worker-playbook-0:0.1.10-1.el9_5 | RHSA-2024:10761 |
| Red Hat Enterprise Linux 9 | python-wheel-1:0.36.2-8.el9 | RHSA-2023:6712 |
| Red Hat Software Collections for Red Hat Enterprise Linux 7 | rh-python38-python-wheel-0:0.33.6-9.el7 | RHSA-2023:6793 |
Frequently Asked Questions
Is CVE-2022-40898 in your dependencies?
Find it across PyPI, including transitive dependencies.