NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2022-4044 — mattermost-server

MEDIUM

CVE-2022-4044 is a medium-severity (CVSS 4.3) CWE-770 vulnerability in github.com/mattermost/mattermost-server. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for github.com/mattermost/mattermost-server — see the affected versions and patch details below.

Authenticated user could send multiple requests containing a large Auto Responder Message payload and can crash a Mattermost server

Also known asGHSA-5jph-wrq7-v9hf
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
1 known
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-4044.

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk+0.02%
Lower risk than most CVEs67th percentile — riskier than 67% of all scored CVEsHighest risk
0.01%0.55%1.10%1.64%0.5%1.1%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost-server

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

A denial-of-service vulnerability in Mattermost allows an authenticated user to crash the server via multiple large autoresponder messages.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/mattermost/mattermost-serverall versions7.1.4go get github.com/mattermost/mattermost-server@v7.1.4
🐹Gogithub.com/mattermost/mattermost-server≥ 7.2.0&&< 7.2.17.2.1go get github.com/mattermost/mattermost-server@v7.2.1
🐹Gogithub.com/mattermost/mattermost-server≥ 7.3.0&&< 7.3.17.3.1go get github.com/mattermost/mattermost-server@v7.3.1

Affected Products

1 product · 1 configurations
Application
mattermostmattermost
< 7.4
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/mattermost/mattermost-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/mattermost/mattermost-server to 7.1.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-4044 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

A denial-of-service vulnerability in Mattermost allows an authenticated user to crash the server via multiple large autoresponder messages.
O3 Security · Impact-Aware SCA

Is CVE-2022-4044 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2022-4044: mattermost-server — Fixed in 7.1.4