NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2022-40127 — apache-airflow

HIGHFix: apache/airflow#25960

CVE-2022-40127 is a high-severity (CVSS 8.8) Code Injection vulnerability in apache-airflow. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for apache-airflow — see the affected versions and patch details below.

Apache Airflow <2.4.0 has an RCE in a bash example

Also known asBIT-airflow-2022-40127GHSA-6pw3-8h9w-32gcPYSEC-2022-42982
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-40127.

EPSS Exploitation Probability

via FIRST.org ↗
85.7%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
83.4%87.4%91.5%95.6%93.3%85.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍apache-airflow

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

A vulnerability in Example Dags of Apache Airflow allows an attacker with UI access who can trigger DAGs, to execute arbitrary commands via manually provided run_id parameter. This issue affects Apache Airflow Apache Airflow versions prior to 2.4.0.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIapache-airflowall versions2.4.0pip install --upgrade 'apache-airflow==2.4.0'

Affected Products

1 product · 1 configurations
Application
airflowapache
< 2.4.0
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for apache-airflow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update apache-airflow to 2.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-40127 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

How to detect CVE-2022-40127

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2022-40127 -u https://target
Template
AirFlow < 2.4.0 - Remote Code Execution
Severity
high
Impact
Successful exploitation of this vulnerability could allow an attacker to execute arbitrary code on the affected system.
Remediation
Upgrade AirFlow to version 2.4.0 or later to mitigate this vulnerability.

Template by ProjectDiscovery nuclei-templates (DhiyaneshDk, ritikchaddha), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

A vulnerability in Example Dags of Apache Airflow allows an attacker with UI access who can trigger DAGs, to execute arbitrary commands via manually provided run_id parameter. This issue affects Apache Airflow Apache Airflow versions prior to 2.4.0.
O3 Security · Impact-Aware SCA

Is CVE-2022-40127 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2022-40127: apache-airflow — Fixed in 2.4.0