CVE-2022-39987 is a high-severity (CVSS 8.8) CWE-77 vulnerability in billz/raspap-webgui. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for billz/raspap-webgui — see the affected versions and patch details below.
RaspAP Command Injection vulnerability
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- A successful exploit gives an attacker total control of the affected component, not partial access.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-39987.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
billz/raspap-webguiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A Command injection vulnerability in RaspAP 2.8.0 thru 2.9.2 allows an authenticated attacker to execute arbitrary OS commands as root via the "entity" POST parameters in /ajax/networking/get_wgkey.php.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | billz/raspap-webgui | ≥ 2.8.0&&< 2.9.5 | 2.9.5composer require billz/raspap-webgui:^2.9.5 |
Affected Products
raspapraspapResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for billz/raspap-webgui, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update billz/raspap-webgui to 2.9.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-39987 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2022-39987 in your dependencies?
Find it across Packagist, including transitive dependencies.