NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🦀
🦀 crates.io
Not in CISA KEV
MEDIUM severity

CVE-2022-39397 — aliyun-oss-client

MEDIUMFix: tu6ge/oss-rs@e4553f7

CVE-2022-39397 is a medium-severity (CVSS 5.6) Information Exposure vulnerability in aliyun-oss-client. A fix is available for aliyun-oss-client — see the affected versions and patch details below.

Exposure of sensitive information in aliyun-oss-client

Also known asGHSA-3w3h-7xgx-grwcRUSTSEC-2022-0089
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-39397.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs41th percentile — riskier than 41% of all scored CVEsHighest risk
0.00%0.32%0.65%0.97%0.3%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🦀aliyun-oss-client

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.

Description

Impact

Users of this library will be affected when using this library, the incoming secret will be disclosed unintentionally.

Patches

This have already been solved.

Workarounds

No, It cannot be patched without upgrading

References

No

For more information

If you have any questions or comments about this advisory:

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🦀crates.ioaliyun-oss-clientall versions0.8.1cargo update -p aliyun-oss-client --precise 0.8.1

Affected Products

1 product · 1 configurations
Application
aliyun-oss-clientaliyun-oss-client_project
< 0.8.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for aliyun-oss-client, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update aliyun-oss-client to 0.8.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-39397 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

### Impact Users of this library will be affected when using this library, the incoming secret will be disclosed unintentionally. ### Patches This have already been solved. ### Workarounds No, It cannot be patched without upgrading ### References No ### For more information If you have any questions or comments about this advisory: * Email us at [email address](mailto:[email protected])
O3 Security · Impact-Aware SCA

Is CVE-2022-39397 in your dependencies?

Find it across crates.io, including transitive dependencies.

CVE-2022-39397: aliyun-oss-client — Fixed in 0.8.1