CVE-2022-39353 is a critical-severity (CVSS 9.4) Improper Input Validation vulnerability in xmldom. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for xmldom — see the affected versions and patch details below.
xmldom allows multiple root nodes in a DOM
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-39353.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
xmldomnpm@xmldom/xmldomnpmDescription
Impact
xmldom parses XML that is not well-formed because it contains multiple top level elements, and adds all root nodes to the childNodes collection of the Document, without reporting any error or throwing.
This breaks the assumption that there is only a single root node in the tree, which led to https://nvd.nist.gov/vuln/detail/CVE-2022-39299 and is a potential issue for dependents.
Patches
Update to @xmldom/xmldom@~0.7.7, @xmldom/xmldom@~0.8.4 (dist-tag latest) or @xmldom/xmldom@>=0.9.0-beta.4 (dist-tag next).
Workarounds
One of the following approaches might help, depending on your use case:
- Instead of searching for elements in the whole DOM, only search in the
documentElement. - Reject a document with a document that has more then 1
childNode.
References
For more information
If you have any questions or comments about this advisory:
- Email us at [email protected]
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | xmldom | all versions | No fix |
| 📦npm | @xmldom/xmldom | all versions | 0.7.7npm install @xmldom/xmldom@0.7.7 |
| 📦npm | @xmldom/xmldom | ≥ 0.8.0&&< 0.8.4 | 0.8.4npm install @xmldom/xmldom@0.8.4 |
| 📦npm | @xmldom/xmldom | ≥ 0.9.0-beta.1&&< 0.9.0-beta.4 | 0.9.0-beta.4npm install @xmldom/xmldom@0.9.0-beta.4 |
Affected Products
debian linuxdebianxmldomxmldom_projectResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for xmldom, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
A fix is available for CVE-2022-39353; check the affected-versions list above or the advisory for the patched release of xmldom, then make sure no transitive dependency still pins the vulnerable range.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2022-39353 in your dependencies?
Find it across npm, including transitive dependencies.