CVE-2022-39294 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in conduit-hyper. A fix is available for conduit-hyper — see the affected versions and patch details below.
(DoS) Denial of Service from unchecked request length in conduit-hyper
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
conduit-hyperReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.
Description
Prior to version 0.4.2, conduit-hyper did not check any limit on a request's length before calling hyper::body::to_bytes. An attacker could send a malicious request with an abnormally large Content-Length, which could lead to a panic if memory allocation failed for that request.
In version 0.4.2, conduit-hyper sets an internal limit of 128 MiB per request, otherwise returning status 400 ("Bad Request").
This crate is part of the implementation of Rust's crates.io, but that service is not affected due to its existing cloud infrastructure, which already drops such malicious requests. Even with the new limit in place, conduit-hyper is not recommended for production use, nor to directly serve the public Internet.
The vulnerability was discovered by Ori Hollander from the JFrog Security Research team.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🦀crates.io | conduit-hyper | ≥ 0.2.0-alpha.3&&< 0.4.2 | 0.4.2cargo update -p conduit-hyper --precise 0.4.2 |
Affected Products
conduit-hyperconduit-hyper_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for conduit-hyper, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update conduit-hyper to 0.4.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-39294 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2022-39294 in your dependencies?
Find it across crates.io, including transitive dependencies.