CVE-2022-39267 is a high-severity (CVSS 8.8) Improper Authentication vulnerability in github.com/brokercap/Bifrost. A fix is available for github.com/brokercap/Bifrost — see the affected versions and patch details below.
Brokercap Bifrost vulnerable to authentication bypass for admin and monitor user groups
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/brokercap/BifrostReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Bifrost is a heterogeneous middleware that synchronizes MySQL, MariaDB to Redis, MongoDB, ClickHouse, MySQL and other services for production environments. Versions prior to 1.8.8-release are subject to authentication bypass in the admin and monitor user groups by deleting the X-Requested-With: XMLHttpRequest field in the request header. This issue has been patched in 1.8.8-release. There are no known workarounds.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/brokercap/Bifrost | all versions | 1.8.7-releasego get github.com/brokercap/Bifrost@v1.8.7-release |
Affected Products
bifrostxbifrostDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/brokercap/Bifrost, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/brokercap/Bifrost to 1.8.7-release or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-39267 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2022-39267 in your dependencies?
Find it across Go, including transitive dependencies.