CVE-2022-3766 is a high-severity (CVSS 7.3) Cross-site Scripting (XSS) vulnerability in thorsten/phpmyfaq. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for thorsten/phpmyfaq — see the affected versions and patch details below.
Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-3766.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
thorsten/phpmyfaqReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Cross-site Scripting (XSS) - Reflected in GitHub repository thorsten/phpmyfaq prior to 3.1.8.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | thorsten/phpmyfaq | all versions | 3.1.8composer require thorsten/phpmyfaq:^3.1.8 |
Affected Products
phpmyfaqphpmyfaqResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
phpMyFAQ 3.1.7 - Reflected Cross-Site Scripting (XSS)
by CodeSecLab · Dec 2, 2025
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for thorsten/phpmyfaq, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update thorsten/phpmyfaq to 3.1.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-3766 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
How to detect CVE-2022-3766
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id cve-2022-3766 -u https://target- Template
- phpMyFAQ < 3.1.8 - Cross-Site Scripting
- Severity
- medium
- Impact
- An attacker can Execute arbitrary JavaScript in victim's browser context
- Remediation
- Upgrade phpMyFAQ to version 3.1.8 or later
Template by ProjectDiscovery nuclei-templates (ritikchaddha), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is CVE-2022-3766 in your dependencies?
Find it across Packagist, including transitive dependencies.