NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

CVE-2022-36633 — teleport

HIGHFix: gravitational/teleport#14726

CVE-2022-36633 is a high-severity (CVSS 8.8) OS Command Injection vulnerability in github.com/gravitational/teleport. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for github.com/gravitational/teleport — see the affected versions and patch details below.

Improper token validation leading to code execution in Teleport

Also known asGHSA-6xf3-5hp7-xqqg
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
3 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
50.3%probability of exploitation in next 30 days
High Risk0.00%
Lower risk than most CVEs99th percentile — riskier than 99% of all scored CVEsHighest risk
24.3%35.0%45.6%56.3%30.3%50.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐹github.com/gravitational/teleport🐹github.com/gravitational/teleport🐹github.com/gravitational/teleport

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Teleport 9.3.6 is vulnerable to Command injection leading to Remote Code Execution. An attacker can craft a malicious ssh agent installation link by URL encoding a bash escape with carriage return line feed. This url encoded payload can be used in place of a token and sent to a user in a social engineering attack. This is fully unauthenticated attack utilizing the trusted teleport server to deliver the payload.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/gravitational/teleportall versions8.3.17go get github.com/gravitational/teleport@v8.3.17
🐹Gogithub.com/gravitational/teleport≥ 9.0.0&&< 9.3.139.3.13go get github.com/gravitational/teleport@v9.3.13
🐹Gogithub.com/gravitational/teleport≥ 10.0.0&&< 10.1.210.1.2go get github.com/gravitational/teleport@v10.1.2

Affected Products

1 product · 1 configurations
Application
teleportgoteleport
< 10.1.2
range
Exploits & PoCs
3

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-51019remotemultiple

Teleport v10.1.1 - Remote Code Execution (RCE)

by Brandon Roach · Sep 23, 2022

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/gravitational/teleport, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/gravitational/teleport to 8.3.17 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-36633 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

Teleport 9.3.6 is vulnerable to Command injection leading to Remote Code Execution. An attacker can craft a malicious ssh agent installation link by URL encoding a bash escape with carriage return line feed. This url encoded payload can be used in place of a token and sent to a user in a social engineering attack. This is fully unauthenticated attack utilizing the trusted teleport server to deliver the payload.
O3 Security · Impact-Aware SCA

Is CVE-2022-36633 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2022-36633: teleport RCE — Fixed in 8.3.17