NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2022-36157 — xxl-job

HIGHFix: xuxueli/xxl-job@730c106

CVE-2022-36157 is a high-severity (CVSS 8.8) Improper Privilege Management vulnerability in com.xuxueli:xxl-job. A fix is available for com.xuxueli:xxl-job — see the affected versions and patch details below.

Improper Privilege Management in com.xuxueli:xxl-job

Also known asGHSA-7qq9-9g2w-56f9
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk+0.03%
Lower risk than most CVEs74th percentile — riskier than 74% of all scored CVEsHighest risk
0.00%8.11%16.2%24.3%19.0%1.5%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕com.xuxueli:xxl-job

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

XXL-JOB all versions as of 11 July 2022 are vulnerable to Insecure Permissions resulting in the ability to execute admin function with low Privilege account.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.xuxueli:xxl-joball versions2.4.0com.xuxueli:xxl-job:2.4.0

Affected Products

1 product · 1 configurations
Application
xxl-jobxuxueli
≤ 2.3.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.xuxueli:xxl-job, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.xuxueli:xxl-job to 2.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-36157 is resolved across your whole dependency graph.

  3. Workarounds

    Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.

Frequently Asked Questions

XXL-JOB all versions as of 11 July 2022 are vulnerable to Insecure Permissions resulting in the ability to execute admin function with low Privilege account.
O3 Security · Impact-Aware SCA

Is CVE-2022-36157 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-36157: xxl-job — Fixed in 2.4.0