CVE-2022-36079 is a high-severity (CVSS 8.6) Information Exposure vulnerability in parse-server. A fix is available for parse-server — see the affected versions and patch details below.
Parse Server vulnerable to brute force guessing of user sensitive data via search patterns
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-36079.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
parse-servernpmDescription
Impact
Internal fields (keys used internally by Parse Server, prefixed by _) and protected fields (user defined) can be used as query constraints. Internal and protected fields are removed by Parse Server from query results and are only returned to the client using a valid master key. However, using query constraints, these fields can be guessed by enumerating until Parse Server returns a response object.
Patches
The patch requires the master key to use internal and protected fields as query constraints.
Workarounds
Implement a Parse Cloud Trigger beforeFind and manually remove the query constraints, such as:
Parse.Cloud.beforeFind('TestObject', ({ query }) => {
for (const key in query._where || []) {
// Repeat logic for protected fields
if (key.charAt(0) === '_') {
delete query._where[key];
}
}
});
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | parse-server | all versions | 4.10.14npm install parse-server@4.10.14 |
| 📦npm | parse-server | ≥ 5.0.0&&< 5.2.5 | 5.2.5npm install parse-server@5.2.5 |
Affected Products
parse-serverparseplatformDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for parse-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update parse-server to 4.10.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-36079 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Frequently Asked Questions
Is CVE-2022-36079 in your dependencies?
Find it across npm, including transitive dependencies.