CVE-2022-36059 — matrix-js-sdk
HIGHCVE-2022-36059 is a high-severity (CVSS 8.2) CWE-1321 vulnerability in matrix-js-sdk. A fix is available for matrix-js-sdk — see the affected versions and patch details below.
Prototype pollution in matrix-js-sdk
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-36059.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
matrix-js-sdknpmDescription
Impact
Events sent with special strings in key places can temporarily disrupt or impede the matrix-js-sdk from functioning properly, potentially impacting the consumer's ability to process data safely. Note that the matrix-js-sdk can appear to be operating normally but be excluding or corrupting runtime data presented to the consumer.
Patches
This is fixed in matrix-js-sdk 19.4.0.
Workarounds
Redacting applicable events, waiting for the sync processor to store data, and restarting the client can often fix it. Alternatively, redacting the applicable events and clearing all storage will often fix most perceived issues.
In some cases, no workarounds are possible.
References
https://learn.snyk.io/lessons/prototype-pollution/javascript/
For more information
If you have any questions or comments about this advisory please email us at security at matrix.org.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | matrix-js-sdk | all versions | 19.4.0npm install matrix-js-sdk@19.4.0 |
Affected Products
javascript sdkmatrixDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for matrix-js-sdk, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update matrix-js-sdk to 19.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-36059 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 7 | thunderbird-0:102.3.0-3.el7_9 | RHSA-2022:6710 |
| Red Hat Enterprise Linux 8 | thunderbird-0:102.3.0-3.el8_6 | RHSA-2022:6708 |
| Red Hat Enterprise Linux 8.1 Update Services for SAP Solutions | thunderbird-0:102.3.0-3.el8_1 | RHSA-2022:6716 |
| Red Hat Enterprise Linux 8.2 Extended Update Support | thunderbird-0:102.3.0-3.el8_2 | RHSA-2022:6715 |
| Red Hat Enterprise Linux 8.4 Extended Update Support | thunderbird-0:102.3.0-3.el8_4 | RHSA-2022:6713 |
| Red Hat Enterprise Linux 9 | thunderbird-0:102.3.0-3.el9_0 | RHSA-2022:6717 |
Frequently Asked Questions
Is CVE-2022-36059 in your dependencies?
Find it across npm, including transitive dependencies.