NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
.NET
.NET NuGet
Not in CISA KEV
HIGH severity

CVE-2022-35909 — Jellyfin.Common

HIGHFix: jellyfin/jellyfin#7569

CVE-2022-35909 is a high-severity (CVSS 8.8) vulnerability in Jellyfin.Common. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for Jellyfin.Common — see the affected versions and patch details below.

Incorrect Access Control and Cross Site Scripting in Jellyfin

Also known asGHSA-qwp3-5fw3-5wgv
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.6%probability of exploitation in next 30 days
Lower Risk+0.03%
Lower risk than most CVEs76th percentile — riskier than 76% of all scored CVEsHighest risk
0.28%0.90%1.52%2.14%0.8%1.6%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
.NETJellyfin.Common

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.

Description

In Jellyfin before 10.8, the /users endpoint has incorrect access control for admin functionality. This lack of access control can be leveraged to performe a cross site scripting attack.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
.NETNuGetJellyfin.Commonall versions10.8.0dotnet add package Jellyfin.Common --version 10.8.0

Affected Products

1 product · 1 configurations
Application
jellyfinjellyfin
< 10.8
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for Jellyfin.Common, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update Jellyfin.Common to 10.8.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-35909 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

In Jellyfin before 10.8, the /users endpoint has incorrect access control for admin functionality. This lack of access control can be leveraged to performe a cross site scripting attack.
O3 Security · Impact-Aware SCA

Is CVE-2022-35909 in your dependencies?

Find it across NuGet, including transitive dependencies.

CVE-2022-35909: Jellyfin.Common XSS — Fixed in 10.8.0