CVE-2022-35697 — core.wcm.components.core
MEDIUMCVE-2022-35697 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in com.adobe.cq:core.wcm.components.core. A fix is available for com.adobe.cq:core.wcm.components.core — see the affected versions and patch details below.
AEM File Upload Security Issue leading to RXSS
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-35697.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
com.adobe.cq:core.wcm.components.coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Core Components version 2.20.6 (and earlier) suffer from a reflected cross-site scripting (XSS) vulnerability in AdaptiveImageServlet via SVG images. An attacker with author access can upload a special crafted SVG image (including a malicious Javascript) and obtain a link that, when loaded by another authenticated users, will execute the malicious script and gain access to other user's session. The issue has been resolved in 2.20.8. There are currently no known workarounds.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | com.adobe.cq:core.wcm.components.core | all versions | 2.20.8com.adobe.cq:core.wcm.components.core:2.20.8 |
Affected Products
web content management core componentsadobeDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.adobe.cq:core.wcm.components.core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update com.adobe.cq:core.wcm.components.core to 2.20.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-35697 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2022-35697 in your dependencies?
Find it across Maven, including transitive dependencies.