NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

CVE-2022-35628 — lux

CRITICAL

CVE-2022-35628 is a critical-severity (CVSS 9.8) SQL Injection vulnerability in in2code/lux. EPSS puts its 30-day exploitation probability at 26.8% (98th percentile). A fix is available for in2code/lux — see the affected versions and patch details below.

SQL Injection in typo3 extension "LUX - TYPO3 Marketing Automation"

Also known asGHSA-rpxg-hg79-h8q9
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
26.8%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs98th percentile — riskier than 98% of all scored CVEsHighest risk
0.00%11.6%23.2%34.8%1.9%26.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘in2code/lux🐘in2code/lux

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

A SQL injection issue was discovered in the lux extension before 17.6.1, and 18.x through 24.x before 24.0.2, for TYPO3.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistin2code/lux≥ 18.0.0&&< 24.0.224.0.2composer require in2code/lux:^24.0.2
🐘Packagistin2code/luxall versions17.6.1composer require in2code/lux:^17.6.1

Affected Products

1 product · 2 configurations
Application
living user experiencein2code
≥ 18.0.0 && < 24.0.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for in2code/lux, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update in2code/lux to 24.0.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-35628 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Frequently Asked Questions

A SQL injection issue was discovered in the lux extension before 17.6.1, and 18.x through 24.x before 24.0.2, for TYPO3.
O3 Security · Impact-Aware SCA

Is CVE-2022-35628 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2022-35628: lux SQL Injection — Fixed in 24.0.2