CVE-2022-35587 is a medium-severity (CVSS 4.8) Cross-site Scripting (XSS) vulnerability in forkcms/forkcms. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for forkcms/forkcms — see the affected versions and patch details below.
ForkCMS XSS via `publish_on_date` parameter
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
forkcms/forkcmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A cross-site scripting (XSS) issue in the Fork version 5.9.3 allows remote attackers to inject JavaScript via the publish_on_date Parameter. This issue was patched in version 5.11.0.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | forkcms/forkcms | all versions | 5.11.0composer require forkcms/forkcms:^5.11.0 |
Affected Products
fork cmsfork-cmsResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for forkcms/forkcms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update forkcms/forkcms to 5.11.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-35587 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2022-35587 in your dependencies?
Find it across Packagist, including transitive dependencies.