CVE-2022-35513 is a high-severity (CVSS 7.5) Broken Cryptographic Algorithm vulnerability in Blink1Control2. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for Blink1Control2 — see the affected versions and patch details below.
Blink1Control2 uses weak password encryption
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
Blink1Control2npmDescription
The Blink1Control2 application <= 2.2.7 uses weak password encryption and an insecure method of storage. Version 2.2.9 fixes the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | Blink1Control2 | all versions | 2.2.9npm install Blink1Control2@2.2.9 |
Affected Products
blink1control2blink1Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Blink1Control2 2.2.7 - Weak Password Encryption
by p1ckzi · Sep 20, 2022
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for Blink1Control2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update Blink1Control2 to 2.2.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-35513 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2022-35513 in your dependencies?
Find it across npm, including transitive dependencies.