CVE-2022-34781 — xlrelease-plugin
MEDIUMCVE-2022-34781 is a medium-severity (CVSS 5.4) CWE-862 vulnerability in com.xebialabs.ci:xlrelease-plugin. A fix is available for com.xebialabs.ci:xlrelease-plugin — see the affected versions and patch details below.
Missing permission checks in Jenkins XebiaLabs XL Release Plugin allow capturing credentials
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-34781.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
com.xebialabs.ci:xlrelease-pluginReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Missing permission checks in Jenkins XebiaLabs XL Release Plugin 22.0.0 and earlier allow attackers with Overall/Read permission to connect to an attacker-specified HTTP server using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins. XebiaLabs XL Release Plugin 22.0.1 requires Overall/Administer permission for the affected form validation methods.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | com.xebialabs.ci:xlrelease-plugin | all versions | 22.0.1com.xebialabs.ci:xlrelease-plugin:22.0.1 |
Affected Products
xebialabs xl releasejenkinsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.xebialabs.ci:xlrelease-plugin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update com.xebialabs.ci:xlrelease-plugin to 22.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-34781 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2022-34781 in your dependencies?
Find it across Maven, including transitive dependencies.